Blue Waters: Cray reveal webinar

CRANY

PRODUCTS SOLUTIONS

Reveal: modules and compilation setup

ar nol dg@z2ol ogi nl1: ~/ openacc-wor kshop/ sol uti ons/ 001-1 apl ace2D- ker nel s>
module list | grep perf
33) perftool s-base/7.0.2
35) perftool s-lite-1oops
( fromhistory )
1046 ftn -c perftools-lite-1oops |aplace.f90
1047 ftn -o |l aplace_f90_reveal |aplace.o
ar nol dg@?2ol ogi nl1: ~/ openacc-wor kshop/ sol uti ons/ 001-1 apl ace2D- kernel s> ftn -
o | aplace_f90_reveal |aplace.o
I NFO creating the CrayPat-instrunented executable 'l aplace f90 reveal
(1 oop_profile)
LK

Get a batch job.

in a job: aprun with perftools-lite-loops
ar nol dg@i d27559: ~/ openacc- wor kshop/ sol uti ons/ 001-| apl ace2D- ker nel s> aprun
-n 1 ./laplace_f90 revea
[PE_O]: MPI rank order: Using default aprun rank ordering.
[PE_O]: rank O is on nid26410
CrayPat/ X: Version 7.0.2 Revision a975333 05/ 16/ 18 15: 45: 29
Jacobi relaxation Cal culation: 4096 x 4096 nesh 0 0.250000 100 0.002397
200 0. 001204

900 0. 000269 conpleted in 102. 654 seconds
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# # # CrayPat-lite Performance Statistics # # #

HUHHRHHHHH T R
CrayPat/ X: Version 7.0.2 Revision a975333 05/ 16/ 18 15:45: 29
Experinment: lite lite/loop_profile

Nunmber of PEs (MPlI ranks): 1

Nunbers of PEs per Node: 1

Nunbers of Threads per PE: 1

Nunmber of Cores per Socket: 8

Execution start tinme: Tue Aug 14 10:53:12 2018

System nanme and speed: ni d26410 2.300 GHz (nomi nal)

AVD Interlagos CPU Fam ly: 21 Model: 1 Stepping: 2

Core Performance Boost: 1 PE has CPB capability

DRAM 64 G B DDRO-#10 on 2.3 GHz nodes



Avg Process Tinme: 103.23 secs

H gh Menory: 275.6 M Bytes 275.6 M Bytes per PE

Tabl e 1: Inclusive and Exclusive Tinme in Loops (from-hprofil e_generate)
Loop | Loop Incl | Tinme | Loop Hit | Loop | Loop | Loop | Function =/.LOOP
[-]

Incl | Time | (Loop | | Trips | Trips | Trips

Time%| | Adj.) | | Avg | Mn | Max

| 99.5%| 102.653319 | 0.000607 | 1 | 1,000.0 | 1,000 | 1,000 | |aplace

_.LooP. 1.1i.41

| 60.4% | 62.263172 | 0.088223 | 1,000 | 4,094.0 | 4,094 | 4,094 | Iaplace
_.LOOP.2.1i.44

| 60.3% | 62.174949 | 62.174949 | 4,094,000 | 4,094.0 | 4,094 | 4,094

| apl ace

_.LOOP.3.1i.45

| 39.2%]| 40.389539 | 0.102904 | 1,000 | 4,094.0 | 4,094 | 4,094 | |aplace
_.LOOP.4.1i.55

| 39.1% | 40.286635 | 40.286635 | 4,094,000 | 4,094.0 | 4,094 | 4,094

| apl ace

_.LOOP.5.1i.56

Program i nvocation: ./l aplace_f90_revea

For a conplete report with expanded tables and notes, run:

pat _report /mmt/a/u/staff/arnol dg/ openacc-workshop/ sol uti ons/ 001-1 apl ace2D-
kernel s/ | apl ace_f 90_r eveal +23727- 26410t

For help identifying callers of particular functions:

pat _report -O callers+src /mt/a/ulstaff/arnol dg/ openacc-wor kshop/ sol uti ons
/ 001-1 apl ace2D- ker nel s/ | apl ace_f90_r eveal +23727- 26410t

To see the entire call tree:

pat _report -O calltree+src /mt/a/u/staff/arnol dg/ openacc-wor kshop

/ sol utions/ 001-1 apl ace2D- ker nel s/ | apl ace_f90_reveal +23727- 26410t

For interactive, graphical perfornmance analysis, run

app2 /mt/a/ u/ staff/arnol dg/ openacc-wor kshop/ sol uti ons/ 001-1 apl ace2D-
kernel s/ | apl ace_f 90_r eveal +23727- 26410t

================ End of CrayPat-lite output ==========================
Application 69044344 resources: utime ~104s, stime ~1s, Rss ~282284,

i nbl ocks ~1 7785, outbl ocks ~37075

ar nol dg@i d27559: ~/ openacc- wor kshop/ sol uti ons/ 001- | apl ace2D- ker nel s>

Here are a couple Apprentice 2 (app2) views of the perftools-lite-loops data as suggested by the output above (interactive, gui performance
analysis ).
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This table shows only lines with:
LU>0.0085
Loop Hit=0
(To set thresholds to zero, specify: -T)

Loop stats can be used in the loop_info compiler directives:

DIR$ LOOP_INFO est_trips(Avg) min_trips(Min) max_trips(Max)
#pragma _CRl loop_info est_trips(Avg) min_trips(Min) max_trips(Max)
The compiler interprets Avg as an estimate, but Min and Max as guarantees.

Times in this table include instrumentation overhead and so may be
larger than times in Profile or other tables.

Table 2: Inclusive and Exclusive Time in Loops (from -hprofile_generate)

Loop| Loopincl| Time| Loop Hit| Leop| Loop| Loep | Function=/.LOOP[]
Incl| Time| (Loop| | Trips | Trips | Trips |
Time% | | Adj)] | Avg| Min| Max|
|
|
199.5% | 102.653319 | 0.000607 | 11,000]1,000] 1,000 | laplace_LOOP.1.1i41
|60.4% | 82.263172| 0.088223 | 1,000 4,094 |4,094 | 4,094 | laplace_LOOP.2.i44
| 60.3% | 62.174949 | 62.174949 | 4,094,000 | 4,094 | 4,094 | 4,094 | laplace_LOOP.3.1.45
|39.2% | 40.389539 | 0.102904 | 1,000 |4,094|4,094 | 4,094 | laplace_LOOP.4.li55
|39.1% | 40.286635 | 40.286635 | 4,094,000 | 4,094 | 4,094 | 4,094 | laplace_LOOP.5.1.56
|

|
Notes for table 3:

Table option:
-0 himem

B8]

(<]

Wallclock time: 103,000000s

Dane {0.00055)

X laplace_f90_reveal+ 23727-26410¢

Ele Compae Vew Hep

M  laplace_0_reveal+23727-264101 a

BHOCD NS

w Overview @) |vmm- o-‘vnxm-pm o-‘vA:dmy Q-‘vamrm o"

Profile

CPU

Function/Region Profile

100.0% = laplace_

p —
-

Load Imha]anm-

Energy Usage
Mo Energy Data Collected

Memory Utilization

Process HiMem (MiBytes) 2756

10011 | _ (10011
10101 10101

Data Movement

Mo data collected.

Walkckock time: 103,0000005

Dane {0.00065)

Notice the loop counts in Table 1. above or Table 2 from the app2 text report--those will also appear in reveal if you provide the

performance_data/ directory path as the 2nd argument.



X my_program.pl — O X
File Edit View Help

~Navigati ~Source - ... dglop rkshop/solutions/001-laplace2D- kernels/ lap lace.fO0
1 [Lnnp Performance o] ] E+ coe/E.4.6 Down || gave | 4
AZ if(mod({iter,100).2q.0 ) write(*, " (is, f10.6)") iter, e=rrer (~]
~ 102, 0000 LAPLACER4l @ |
53 iter = iter + 1
lpz, 0000 Instance # 54
P G2, 0000 LAPLACER4S5 . ! Directive inserted by Cray Reveal. May ke incomplete.
- 62,0000 LAPLACER44 | !'$0MF parallel deo default(ncne)
! 5OMF& private (i, J)
BZ, 0000 T i
netanss # ! SOMEP& shared  (a, ancw)
< 40,0000 LAPLACE@SE |1
40, DODD Instance # LS uE do i=1,n-2
LAPLACERSS | 7 |- 57 B{i, §) = Anew(i, )
40, 000 . end do
Imnt'aluistafiiamokdg/ope nacc-wolshop/solutio n=/001-
laplace20-ke me 'lap lace f00 end do
LAPLACE@SS
Avg Trps: 4,094
Min Trps: 4,094 end do
Max Trp=: 4,094
Total Hits: 1,000 ) )
Loop scoped withaut emors. call cpu_time({stop_time)
Potential OMP speedup of 30,000000 ssconds. write(*,'(a,f10.3,a)") ' completed in ', stop_time-start_time, ' sec[ |
C

[ D]

~Infi

(<] [ [>)

my_program.pl/ loaded. laplace_fo0 reveal+23727-26410¢ |caded. _

create a program library for reveal

ar nol dg@?2ol ogi nl1: ~/ openacc-wor kshop/ sol uti ons/ 001-1 apl ace2D- kernel s> ftn -
@B -hpl=ny_programpl -c |aplace.f90

Analyze with Reveal--the performance_data/ is the directory generated from the loop analysis job's aprun.

launch reveal

ar nol dg@z2ol ogi nl1: ~/ openacc-wor kshop/ sol uti ons/ 001-1 apl ace2D- ker nel s>
reveal ny_programpl/ |aplace_f90 reveal +23727-26410t/




X my

- m] x

Fie Edit Vew Hep X Reveal OpenMP Scoping
. fsh |utions/001-laplace2D-]
P P ker .
- Scope Loops | Scoping Results
Loop Performance ) Q

T i e List of Loops to be Scoped
[ 102, 0000 LAPLACERAL

50 =nd do T " n (=]
b i2,0000 uarnacEges * Scope? Line#  Fike orSource Line
b £2, 0000 LAPLACERdA o f(med{iter, 100).aq.0 ) write(®, (3 - fmntfafufstafffarncldg/openace-workshop/solutions/001-laplace?b-karnalsflaplac
3 40,0000 LAPLACERSE 23 iter = iter + 1 41 Loop in function LAFLACE

44 Loop in function LAFLACE
40, 000D Instance #1
43 Loop in function LAFLACE
as 6 de i=1,n-2

s S gy - ey 3% Loop in function LAFLACE

2B =nd do 36 Loop in function LAFLACE

1 =nd de

60

61  =nd do

62

62 call cpu_time(stop_time)

64 writs(",'(a,f10.3,2)') ' completed if

[

BE  deallccats (A, Anew)

£7 =nd program lapla

~Info - Line
19 A loop starting at line 55 wes scoped without ermors.

@ A loop starting at line 35 wee not vectorized becavee it containe a call to a subm
0 A loop starting &t line 36 wes replaced by a lbry call [.sppr,rFinarl Tirne:[o‘ooo |2] Trps

B

my_progiam pl' keckd. kplace {0 mveak2z3727-2541 01 loackd.

X my_program.pl

Fie Edt Vew Hep X Reveal OpenMP Scoping - O *
~Source - ... P i /00 -lapl; D-ker 2
Szape Loops | Scoping Results
p Performance C|
= - e laplace.f90: Loop@5s
10z, 0000
LAFLACEQLL @ 50 end do Mame Type Scope Info
[ £2,0000 LAPLACER4S l .1
2 Scalar Private
[ £2,0000  LAPLACER4d W 2 if(mod{iter, 100) .2q.0 ) writ=(*,"(i
B 40,0000 narLAcE@SE [ Cter e iter s 1 i Scalar  Private
a Anay Shared
40, 000D Instance #1 anew Amay Shared
do i-1,n-%
37 Ati, §) - An=wii, §)
B =nd de X OpenMP Directive - [m} x
2 =nd de | Directive Inserted by Cray Reveal, May be incomplete,
5D 1$0OMP pamlkel do defaultinons) &
61 =nd do 1BOMPE  private (i.j) &
- 1$OMPs shakd (aanew)
63 call cpu_time(stop_time)
B4 writs(*,"(a,£10.3,2)") ' completsd i

Es
13 d=allccate (A, Anew)

§7 =nd program laplace

~info - Line O Fril
1 A locp starting at line 55 wes scoped without enors
@ A bop starting at line 55 was not vectorized becalse it contains & call to a s ubm O i
W A locp starting at line 56 was epaced by a lbrary call.

Copy Diective l [ 3¢ cenar l
Find Name:

my_program.pll keded. leplace_fen_mveakzarar-254 ot leadsd.




File Edit Wiew Hslp

~Navigation
< | Loop Performance o l E+ ]

~Source - ... kg'openace-workshop/solutions/001-laplace2D-kemels/laplace 190

coe/B.4.6 Down || Save ﬂ

B
B
B
B

102, 0000 LAPLACER4l
62,0000 LAPLACER45 [
62,0000 LAPLACER44 [
40,0000 LAPLACERSE ||

LAPLACERSS

40, 0000 Instance

AS

a2
53
54

if{mod(iter,100).eg.0 ) write(*,'(is, f10.6)"') diter, errcr sl
iter = iter + 1
! Directive inserted by Cray Reveal., May be incomplete.

!%0MF parallel do default{none)
| SOMF& private (i, §)
! SOMF& shared (a, ancw)

do i=1,n-2
Ali, ) = Anew(i, )

end do

end do

=nd do

call cpu_time(stop_time)

write(*,'{a, £f10.3,a)") ' completed in ', stop time-start_time, |

|X| my_program.pl

File Edit ¥iew Help
igatie ~Source - ... kg | 1001-laplace2D-kernels/laplace f90.
+ | Loop Performance a l & E] coe/B.4.6 &
s (]
= 102, 0000 LAPLACE@4l @7 52 if(med(iter, 100) .eq. D ) write(®,'(i5,f10.6)') iter, error |
102, 0ODD Instance #1 53 iter = iter + 1
- 62,0000 LAPLACE@4S |||/ S
20000 tostanee £ o e e e
- 6%, 0000 LAPLACE@44 [N | SOMP& private (i, 3J)
62, 0000 ThetRRce 1 ! SOMP& shared (a, anew)
b 40,0000 LAPLACE@SS ||
" AS 56 do i=1,n-2
LAPLACE@55
Ly Ali, J) = RAnew(i, J)
40, DODD Instance #1 i
£ =nd do
60
61 end do
62
{35 call cpu_time(stop_time)
64  writc(*,'(a,f10.3,a)') ' completed in ', stop_time-start_time, ' sccom
65
66  deallocate (A, Rnew)
67 end program laplace -]
(] [ D
~Info- Line 55
[ Aloop starting at line 55 was scoped withouterrors
@ A loop starting at line 55 was not vectorized because it contains a call to a subroutine or function on line 5.
[ Aloop starting at line 56 was replaced by a library call
|my_program.p| loaded. laplace _{90_reveal+23727-26410t loaded. 5 | _
If you let Reveal insert OpenMP directives, they will be maintained in your Reveal sessions for the current program library. To save
them to the filesystem, filesave in Reveal.

Rebuild the code and run it again with OpenMP threads:

Test the OpenMP version from reveal, rebuilt with "ftn"

ar nol dg@?2ol ogi n3: ~/ openacc-wor kshop/ sol uti ons/ 001-1 apl ace2D- kernel s> ftn

| apl ace. f90 -h nsgs



A = 0.0 fp_kind
ftn-6066 crayftn: SCALAR LAPLACE, File = laplace.f90, Line = 28 A | oop
nest at line 28 collapsed to a single |oop

ftn-6230 crayftn: VECTOR LAPLACE, File = laplace.f90, Line = 28 A | oop
starting at line 28 was replaced with nmultiple library calls.

Anew = 0.0 _fp_kind
ftn-6004 crayftn: SCALAR LAPLACE, File = laplace.f90, Line = 29 A | oop

starting at line 29 was fused with the |loop starting at |ine 28.

A(O,:) = 1.0 fp kind
ftn-6332 crayftn: VECTOR LAPLACE, File = laplace.f90, Line = 32 A | oop
starting at line 32 was not vectorized because it does not map well onto
the target architecture
ftn-6005 crayftn: SCALAR LAPLACE, File = laplace.f90, Line
starting at line 32 was unrolled 8 tines.

Anew(0,:) = 1.0 _fp_kind
ftn-6004 crayftn: SCALAR LAPLACE, File = laplace.f90, Line = 33 A | oop
starting at line 33 was fused with the |loop starting at |ine 32.

call cpu_tinme(start_tine) A
ftn-3021 crayftn: | PA LAPLACE, File = laplace.f90, Line = 37, Colum = 8
" CPUTIME 8" (called from"laplace") was not inlined because the conpiler
was unable to | ocate the routine.

do while ( error .gt. tol .and. iter .It. iter_max )
ftn-6286 crayftn: VECTOR LAPLACE, File = laplace.f90, Line = 41 A | oop
starting at line 41 was not vectorized because it contains input/output
operations at |ine 57.
I$OWP parallel do default(none) &
ftn-6823 crayftn: THREAD LAPLACE, File = laplace.f90, Line = 45 A region
starting at line 45 and ending at line 55 was nulti-threaded.

do j=1,m2
ftn-6294 crayftn: VECTOR LAPLACE, File = laplace.f90, Line = 49 A | oop
starting at line 49 was not vectorized because a better candi date was
found at |ine 50.
ftn-6817 crayftn: THREAD LAPLACE, File = laplace.f90, Line = 49 A | oop
starting at line 49 was partitioned.
do i=1,n-2 ftn-6005 crayftn: SCALAR LAPLACE, File = |aplace.f90
Line =50 A loop starting at line 50 was unrolled 6 times. ftn-6204
crayftn: VECTOR LAPLACE, File = | aplace.f90, Line = 50 A loop starting
at line 50 was vectorized.
I $OVMP parallel do default(none) &
ftn-6823 crayftn: THREAD LAPLACE, File = laplace.f90, Line = 61 A region
starting at line 61 and ending at line 68 was nulti-threaded.
do j=1,m2
ftn-6294 crayftn: VECTOR LAPLACE, File = laplace.f90, Line = 64 A loop
starting at line 64 was not vectorized because a better candi date was
f ound at |ine 65.
ftn-6817 crayftn: THREAD LAPLACE, File
starting at line 64 was partitioned.
do i=1,n-2

ftn-6202 crayftn: VECTOR LAPLACE, File | apl ace. f90, Line = 65 A | oop
starting at line 65 was replaced by a library call

call cpu_tinme(stop_tine) n
ftn-3021 crayftn: | PA LAPLACE, File = laplace.f90, Line = 72, Colum = 8
" CPU TIME 8" (called from"laplace") was not inlined because the conpiler

32 Aloop

| apl ace.f90, Line = 64 A loop



was unabl e to |l ocate the routine.

Cray Fortran : Version 8.4.6

(20160328193024_838f eabbbef 776e483380adecf 458b3df f 3 03cd0)
Cray Fortran : Wed Aug 15, 2018 09:44:24

Cray Fortran : Conpile time: 0.3120 seconds

Cray Fortran : 76 source |ines

Cray Fortran : O errors, O warnings, 18 other nessages, 0 ans

ar nol dg@i d25355: / mt / a/ u/ st af f/ ar nol dg/ openacc-wor kshop/ sol uti ons/ 001-
| apl ace2D- kernel s> ti me OVP_NUM THREADS=8 aprun -n 1 -d 16 ./a.out
[PE_O]: MPI rank order: Using default aprun rank ordering.

[PE_O]: rank O is on nid26361

Jacobi relaxation Cal culation: 4096 x 4096 nesh

0 0.250000 100 0.002397 200 0.001204 300 0.000804 400
0.000603 500 0.000483 600 0.000403 700 0.000345 800 0.000302
900 0.000269 conpleted in 358. 486 seconds

Appl i cation 69060514 resources:

utine ~359s, stime ~1s, Rss ~264432, inblocks ~10932, outbl ocks ~27567
real 0m48. 949s user Onmdl. 828s sys On0. 360s

SPEEDUP (not linear) ! Success.
time command

Using the time command in conjunction with other performance tools is "free". You should get into the habit of timing your code with
time so that you have an accurate accounting of the wall time used for your code.

See "man reveal" to review the steps and for further information.



arncldg@h2ologind:...-laplace2D-kemels - O *

Program Li

file3.

1loring the

Manual page reveal (l) line 133

arncldg@h2ologind:...-laplace2D-kemels - O *

ftn -c my
ftn -o my

Manual page reveal(l) line 97

The reveal quickstart help screen has detailed information about how to use the GUI.




X Reveal - Getting Started — O x
Getting Started
e e
% reveal my_program_library
If you don't have a program library, use CCE to create one when compiling your program:
% cc -h pl=my_program_library ...
or
% ftn -h pl=my_program_library ...
Note:
if you move or copy your program library to a different location, you must also
include your source because the library references the source with relative paths.
= Launching Reveal Client from your Desktop
- Double click on Reveal icon to launch the tool
- Select File->Open and select New Host from the Hostname menu to log onto a Cray login nede.
- Type in desired host name. You will be prompted for password to connect.
= Including Performance Data
If you collect loop statistics using CCE and CrayPat, you can include this data by
selecting File->Attach Performance Data or by including it on the command line when
launching Reveal as in the following example:
% reveal my_program_library my_perf_data_directory
= Including Memory Analysis Data
If you collect memory analysis data using CCE and CrayPat, you can include this

data by selecting File->Attach Memory Analysis Data. -
~ Source Navigation

- Selecting a file name in the navigation panel brings the source into the
source panel for viewing.

- The source panel contains a celumn of loopmark information.
See 'Help -> Loopmark Legend' for an explanation of the symbols used.

- The File Selection' option in the 'View' menu can be used to select
which files are shown in the navigation panel views.

- Files, functions and loops which have been scoped are highlighted with a green
square for positive results, a red circle for negative results or a red/green square
for a mixture of both

|xgsns.|

CCE only

Your code needs to build with PrgEnv-cray and CCE (the Cray Compiler Environment) in order to use reveal.

References:

https://bluewaters.ncsa.illinois.edu/reveal-and-openmp
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